TLS 1.3 Support for .Net 4.0 compiled application

I have an application compiled to in .Net 4.0(require this to support backward compatibility) and it does support TLS 1.2 when we install .Net higher version on the workstation.
Does this scenario remains the same to support TLS 1.3 installing .Net 4.8 runtime on the workstation without compiling application to .Net 4.8 and just target the .Net 4.8 runtime in our application.

.NET Foundation Website | Blog | Projects | Code of Conduct