Testing Template Project Windows Community on Linux


#1

Hello,

Wow , the project is almost completly working on any platform simlessly ! great job .

I host the too sample WebHello and Mvc Hello

I created a project with Visual Studio Community 2015, with rc1 ASP.NET 5.0,
Copy the project to linux

This is the Project.json

{
“userSecretsId”: “aspnet5-Booty-a7e199d3-1ff2-431b-b3d5-adc1e7728397”,
“version”: “1.0.0-*”,
“compilationOptions”: {
“emitEntryPoint”: true
},

“dependencies”: {
“EntityFramework.Commands”: “7.0.0-rc1-final”,
“EntityFramework.MicrosoftSqlServer”: “7.0.0-rc1-final”,
“Microsoft.ApplicationInsights.AspNet”: “1.0.0-rc1”,
“Microsoft.AspNet.Authentication.Cookies”: “1.0.0-rc1-final”,
“Microsoft.AspNet.Diagnostics.Entity”: “7.0.0-rc1-final”,
“Microsoft.AspNet.Identity.EntityFramework”: “3.0.0-rc1-final”,
“Microsoft.AspNet.IISPlatformHandler”: “1.0.0-rc1-final”,
“Microsoft.AspNet.Mvc”: “6.0.0-rc1-final”,
“Microsoft.AspNet.Mvc.TagHelpers”: “6.0.0-rc1-final”,
“Microsoft.AspNet.Server.Kestrel”: “1.0.0-rc1-final”,
“Microsoft.AspNet.StaticFiles”: “1.0.0-rc1-final”,
“Microsoft.AspNet.Tooling.Razor”: “1.0.0-rc1-final”,
“Microsoft.Extensions.CodeGenerators.Mvc”: “1.0.0-rc1-final”,
“Microsoft.Extensions.Configuration.FileProviderExtensions” : “1.0.0-rc1-final”,
“Microsoft.Extensions.Configuration.Json”: “1.0.0-rc1-final”,
“Microsoft.Extensions.Configuration.UserSecrets”: “1.0.0-rc1-final”,
“Microsoft.Extensions.Logging”: “1.0.0-rc1-final”,
“Microsoft.Extensions.Logging.Console”: “1.0.0-rc1-final”,
“Microsoft.Extensions.Logging.Debug”: “1.0.0-rc1-final”,
“Microsoft.VisualStudio.Web.BrowserLink.Loader”: “14.0.0-rc1-final”
},

“commands”: {
“web”: “Microsoft.AspNet.Server.Kestrel --server.urls http://*:5000”,
“ef”: “EntityFramework.Commands”
},

“frameworks”: {
“dnx451”: { },
“dnxcore50”: { }
},

“exclude”: [
“wwwroot”,
“node_modules”
],
“publishExclude”: [
".user",
"
.vspscc"
],
“scripts”: {
“prepublish”: [ “npm install”, “bower install”, “gulp clean”, “gulp min” ]
}
}

dotnet restore command is failing :[

/src/Booty$ dotnet restore
log  : Restoring packages for /home/zvn/proj/Booty/src/Booty/project.json...
error: Unable to resolve EntityFramework.Commands (>= 7.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve EntityFramework.MicrosoftSqlServer (>= 7.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.ApplicationInsights.AspNet (>= 1.0.0-rc1) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.AspNet.Authentication.Cookies (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.AspNet.Diagnostics.Entity (>= 7.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.AspNet.Identity.EntityFramework (>= 3.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.AspNet.Mvc.TagHelpers (>= 6.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.AspNet.Tooling.Razor (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.Extensions.CodeGenerators.Mvc (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.Extensions.Configuration.FileProviderExtensions (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.Extensions.Configuration.UserSecrets (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.Extensions.Logging.Debug (>= 1.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve Microsoft.VisualStudio.Web.BrowserLink.Loader (>= 14.0.0-rc1-final) for DNX,Version=v4.5.1.
error: Unable to resolve EntityFramework.Commands (>= 7.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve EntityFramework.MicrosoftSqlServer (>= 7.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.ApplicationInsights.AspNet (>= 1.0.0-rc1) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.AspNet.Authentication.Cookies (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.AspNet.Diagnostics.Entity (>= 7.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.AspNet.Identity.EntityFramework (>= 3.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.AspNet.Mvc.TagHelpers (>= 6.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.AspNet.Tooling.Razor (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.Extensions.CodeGenerators.Mvc (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.Extensions.Configuration.FileProviderExtensions (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.Extensions.Configuration.UserSecrets (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.Extensions.Logging.Debug (>= 1.0.0-rc1-final) for DNXCore,Version=v5.0.
error: Unable to resolve Microsoft.VisualStudio.Web.BrowserLink.Loader (>= 14.0.0-rc1-final) for DNXCore,Version=v5.0.
log  : Committing restore...
log  : Restore failed in 860ms.
Errors in /home/zvn/proj/Booty/src/Booty/project.json
    Unable to resolve EntityFramework.Commands (>= 7.0.0-rc1-final) for DNX,Version=v4.5.1.

#2

use dnx for rc1 , dotnet restore has is still not ready.


.NET Foundation Website | Blog | Projects | Code of Conduct