PROBLEM Install .NET Core SDK on Ubuntu Linux 17.04 = 'libicu55' package has no candidate for installation -NEED UPDATE TO libicu57


#1

There is a problem following theses steps to Install .NET Core SDK on Ubuntu Linux 17.04

When I get to this step

The Linux tell me that cannot install by the miss of libicu55

Reading package lists … Ready
Building dependency tree
Reading status information … Ready
Some packages could not be installed. This may mean that
you asked for an impossible situation or, if you are using the
that some required packages were not
created yet or were taken from the “Incoming”.
The following information may help resolve the situation:

The following packages have mismatched dependencies:
dotnet-runtime-2.0.0: Depends: libicu55 but is not installable
E: Impossible to fix problems, you kept (hold) broken packages.

So, when i tried to install the libicu55 i got this surprise

Reading package lists … Ready
Building dependency tree
Reading status information … Ready
The libicu55 package is not available, but is referenced by another package.
This may mean that the package is missing, has become obsolete, or
is available only from another source

E: ‘libicu55’ package has no candidate for installation

So, and i found some think curious thinks, i write libicu “and click TAB” to see the libicu updated… and i found the libicu57

erik@erik-Inspiron-5548:~$ sudo apt-get install libicu "TAB"
libicu4j-4.2-java libicu4j-49-java libicu4j-java-doc libicu57-dbg
libicu4j-4.4-java libicu4j-java libicu57 libicu-dev

You need update this install and tutorial to use libicu57


.NET Foundation Website | Blog | Projects | Code of Conduct