Getting Started Guide causes errors on Digital Ocean ubuntu 14.04 server


#1

Hey everyone,

I thought I would give running some code on Ubuntu a shot so I followed the guide at: http://dotnet.github.io/getting-started/

I’ve tried a fresh DigitalOcean server as well as one that is already running a lemp stack and I get the same message every time:

root@Louis:~# sudo apt-get install dotnet
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package dotnet is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘dotnet’ has no installation candidate

I assume the problem has something to do with DigitalOcean customized sources list or some other DigitalOcean specific issue.


##Update

I’ve tried it on a local VM as well from the latest Ubuntu download 14.04.3 LTS and get the same results.

I’m assuming that this worked at least once, since the Getting Started Guide says:

Note: as of now, the below instructions work on Ubuntu 14.04 and derivatives. New versions are coming up soon!

Apparently it is now broken however.


###Update

I get much further after changing Step 2 of the getting started guide to:

sudo apt-get install dotnet-nightly

I can now run step 3:

dotnet new

and start Step 4:

dotnet restore

But actually running still fails.

dotnet run

returns:

Could not resolve coreclr path.

I’m assuming there is a config step that is missing here.


#2

May be digital ocean doesn’t have some dependencies , from the top my head i recall that libunwind8, libicu, libcurl, llvm (for debugging not required) and may be a few others. If some of them are missing or the versions are mismatching than may be that is the problem. You can analyze the package for its dependencies too to see what exactly is required by the package and what is not available.


#3

Thanks @shahid_pk, that helped me get further. I’ve updated the post with current status.


#4

yup that is known issue with the nightly-builds .deb a workaround is here https://github.com/dotnet/cli/issues/862


#5

Great. Including the work-around here.

Basically the nightly build doesn’t install to the targeted path. To get it working create a symlink from the nightly path to the correct path.

sudo ln -s /usr/share/dotnet-nightly /usr/share/dotnet


.NET Foundation Website | Blog | Projects | Code of Conduct