Framework 4.7.2 & 4.7.1 NOT for Win 10 pro?


#1

Greetings, I just installed a program , that needs 4.7.1 and it sent me to MS to download,
https://dotnet.microsoft.com/download/thank-you/net472
when I tried installing it, I got a message not for win 10 ? I tried both 4.7.2 and 4.7.1

any suggestions are greatly appreciated

thank you

I had just installed it w10p and after I did a update that took 1.5 hours it finally worked

thank you both


#2

Pretty sure .NET 4.7.x is part of Windows 10. Update your Windows 10 computer should get you all the versions you need normally.

Go to “Settings->Update & Security->Check for updates”


#3

I have Windows 10 Pro with .NET Framework 4.7.2 installed. If you have VS 2017 or 2019, you could also install the .NET Framework 4.7.2 SDK using the Visual Studio Installer. But that’s if you’re building the app. To run it, you should just need the .NET Framework 4.7.2 runtime. And zezba9000’s suggestion might do the trick.


#4

problem solved thank you all


.NET Foundation Website | Blog | Projects | Code of Conduct