CoreCLR on Win7: api-ms-win-core-winrt-string-l1-1-0 is missing


#1

I cloned CoreCLR from GitHub and successfully built on Windows 7. However it doesn’t run. I tried

%CORE_ROOT%\CoreConsole.exe hello.exe

with a simple application, and I receive the error

The program can’t start because api-ms-win-core-winrt-string-l1-1-0 is missing from your computer. Try reinstalling the program to fix this problem.

Please help! (Or point me to the appropriate forum.) Why is it referring to winrt on Windows 7? Do I need to install something?


#2

Hi @KeithLRobertson,

Unfortunately I don’t know of a fix for this currently however there are these two issues open:
https://github.com/dotnet/coreclr/issues/65
https://github.com/dotnet/corefx/issues/625


#3

Ah, so it’s a known issue, good. Thanks for your quick response!


#4

Hi @ProTip @KeithLRobertson, I also encounter this issue.


#5

Hi @ProTip @KeithLRobertson, I copied all dlls from this folder
<…\coreclr\tests\src\packages\Microsoft.DotNet.CoreCLR.TestDependencies.1.0.0-prerelease\lib\aspnetcore50>
to target product debug/release folder, and then run corerun.exe, it works.


#6

Hi @cpplog,

Thanks for that, worked here too :slight_smile: Luckily it doesn’t require building the tests to completion, because that failed too :expressionless: Looks like the builds are very WIP still but it worked in the end. Next stop, linux.


#7

Hi @cpplog, Thanks from me, too! Adding the aspnetcore50 folder path to the PATH also does the trick.


#8

Had same problem, also building on Win 7 - SOLVED by copying DLLS from that directory (PATH would probably also work), thanks!


.NET Foundation Website | Blog | Projects | Code of Conduct